在PDF中测量距离

您可以使用测量工具来测量文档中对象的距离和面积。当您要确定表单或辅助设计文件中对象的距离或面积,或者要在发送文档到专业打印机之前测量文档的某些区域时,测量工具特别有用。测量工具仅在PDF文档创建者允许测量的情况下可用。   

当您在使用测量工具时,工具对话框会显示拖画线段的测量信息。

测量对象

Ÿ  请选择“注释”>“测量”>“距离”来测量两点之间的距离。测量距离时,您可以在“测量”偏好设置中设定是否在距离的两端显示默认引线。请单击第一点,移动指针到第二点,然后再次单击。如您选择使用默认引线,移动鼠标确定引线长度,然后在文档中再次点击结束测量。测量信息将显示在工具对话框中。

Ÿ  请选择“注释”>“测量”>“周长”来测量多点之间的一组距离。请单击您要测量的每一点并双击最后一点。

Ÿ  请选择“注释”>“测量”>“面积”来测量拖画线段内的区域面积。请单击您要测量的每一点,在您至少已单击了两个点之后,请单击第一点或双击最后一点来完成面积测量。

注:

1.       测量时按住SHIFT键可沿水平、垂直或对角线(45度)方向绘制直线。

2.       您可以通过右键菜单选择完成或取消测量。

选择某个测量工具后,右侧面板上将出现“格式”选项卡,您可以校准缩放率、自动吸附和导出测量标注等。

Ÿ  如果您的PDF文件嵌入了缩放率,您可以使用嵌入的缩放率来测量距离/周长/面积。使用嵌入的缩放率测量之前,您需要在“文件”> “偏好设置”> “测量”中勾选“如果存在,使用文档的缩放和单位”选项。勾选后,您在文档中的测量才会使用到嵌入的缩放率。为了获取更准确的测量结果,您可以校准文档的缩放比例,请选择以下任一方式:

Ø   若已勾选“如果存在,使用文档的缩放和单位”选项:

1)          在“格式”选项卡中点击“校准”0.png,然后点击直线的两个端点(该直线的实际长度已知)。提示:绘制时按住SHIFT键可沿水平、垂直或对角线(45度)方向绘制直线。也可以点击“格式”选项卡中的“对齐路径的附近点”1.png以自动对齐到页面中的路径。

2)          点击直线的第二个端点后,弹出“校准”对话框。

3)          输入该直线的实际长度,选择对应的单位,然后将生成一个新的比率。

4)          (可选)如果您已知正确的缩放比率,则直接在“格式”选项卡中输入测量值并选择适当的单位。

5)          然后在弹出的“校准”对话框中点击“在页面中存储范围”将新的缩放比率应用到当前页面,或点击“应用到所有页面”应用到所有页面。(或点击“格式”选项卡中的2.png或3.png图标,将新的缩放比率应用于当前页面或所有页面。)新的缩放比率将嵌入到当前页面或所有页面中,同时替换原来嵌入在文档中的缩放比率。

6)          新的缩放比率嵌入到文档中时,文档中的测量值也会相应改变。

Ø   若未勾选“如果存在,使用文档的缩放和单位”选项,直接在“格式”选项卡中设定自定义缩放比率,或在“格式”选项卡中点击“校准”0.png并设定新的缩放比率。设定的缩放比率将仅应用于当前页面。

Ÿ  在“格式”选项卡中勾选“显示结果信息”将显示当前测量的结果,包括测量结果、角度、缩放比例等。

Ÿ  在“格式”选项卡中勾选“测量标记”以添加和显示您在PDF文件中所画的测量线段。勾选该项后,您可以使用“测量”偏好设置中设置的标签或直接在“添加标签”框中输入新的内容来添加标签。距离标注的标签将显示在距离的测量线段上,周长和面积的标签则显示在它们的注释弹出框中。手型工具模式下,当鼠标置于测量标注上方时,您也可以查看到测量结果和标签。将显示测量的标记(如上图红色双箭头所指的距离),且可在右方“注释”框内输入文本,显示在测量标记的注释弹出框中。

Ÿ  在“格式”选项卡中勾选“标尺”将显示标尺。

Ÿ  在“格式”选项卡中选择一种或多种光标吸附方式。当您移动光标时,该功能可使光标自动定位到精确的位置,有助于提高测量的精确性。

吸附端点4.png:当光标靠近线段的一端时将自动定位到端点处,并以红色小圆圈显示。

吸附中点5.png:当光标靠近线段的中点时将自动定位到中点处,并以红色小圆圈显示。

吸附路径1.png:当光标靠近某条线段时将自动定位到线段上,并以红色小方框显示。

吸附交点1.png:当光标靠近两条线段的交点时将自动定位到交点处,并以红色十字形光标显示。

Ÿ  在“格式”选项卡中选择“导出为Excel”将PDF中的测量信息保存到CSV文件中。

注:如果您未勾选“测量标记”,则您所拖画的对象将消失。

编辑测量标记

在完成测量操作后,您可以对测量标记进行其它的编辑操作,如移动位置、调整大小、翻转及其它类似注释的操作等等。

1.         移动测量标记

Ÿ  请选择手型工具或“选择标注”命令,点击您要移动的测量对象。

Ÿ  将光标放置于测量对象中,待光标变为2.png形状时,按住鼠标左键,将测量对象拖至其它位置。

Ÿ  (仅适用于距离测量标记)移动标签和显示在距离测量标记上的测量结果:点击标记上的文本激活文本光标3.png>直接拖动标签到目标位置。

2.         更改线段长度和方向

Ÿ  请选择手型工具或“选择标注”命令,点击测量对象,选择其中一个缩放点4.png,此时光标将变为5.png。

Ÿ  左键拖动即可更改线段的长度和方向。

3.         翻转测量标记和注释

Ÿ  请选择手型工具或“选择标注”命令。

Ÿ  右击您所绘制的测量对象 > 选择“翻转”。

4.         添加、编辑或删除测量标签

测量标签将根据您在“测量”偏好设置中或添加测量标注时的设置添加和显示在测量标注中。若测量标注中没有标签,您可以使用Foxit PDF Editor快速为其添加标签。您还可以编辑和删除已有标签。步骤如下:

·            选择手型工具或“选择标注”工具。

·            为无标签的测量标注添加标签:右击测量标注 > 选择“添加标签” > 自定义输入标签 > 点击“确定”。

·            编辑已有标签:右击测量标注 > 选择“编辑标签”> 自定义输入标签 > 点击“确定”。

·            删除标签:右击测量标注 > 选择“删除标签”。

将测量标记作为注释

测量标记也可以被当作注释处理。您可以设置状态、打开注释弹出框、删除注释、回复注释、更改属性以及将当前属性设为默认。

注:如需显示测量标记和测量结果,请右击您绘制的对象,然后选择“属性”>“外观”> 勾选“线条上显示文本”。

关于如何将测量标记作为注释进行处理的信息,请参阅“第七章 - 注释”中的相应部分。

更改测量标记的外观

Foxit PDF Editor提供了多种更改测量标记的外观的方式。当您选中一个测量标记时,一个工具栏会浮动在测量标记上方,您可以快速更改线条颜色。您还可以通过右侧面板中的“格式”选项卡以及“属性”对话框进行更高级的设置。若通过“格式”选项卡更改外观,程序将保存属性并将其应用于新的测量标记。若通过“属性”对话框更改外观并且没有在对话框中勾选“将当前属性设置为默认”选项,该属性将仅应用于当前选定的标记。

²  通过“格式”选项卡更改外观

·         请选择手型工具或“选择标注”命令。

·         点击要更改外观的测量标记,然后右侧面板中将出现“格式”选项卡。

·         根据需要执行以下任一操作:

Ø  更改线条颜色:在“形状类型”组中选择一种预设颜色,或点击“线条颜色”按钮1.png并从调色板中选择所需的颜色。

Ø  更改不透明度:点击“不透明度”按钮2.png,然后拖动滑块更改不透明度。

Ø  设置填充色:点击“填充色”按钮3.png,然后从调色板中选择所需的颜色。

Ø  更改线宽:在“线宽”域4.png中,输入一个值,或从下拉列表中选择所需的值。

Ø  更改虚线样式:点击“虚线样式”按钮5.png,然后根据需要选择一种虚线类型。

Ø  更改线头/线尾的形状:在“线头”或“线尾”组中选择所需的形状。

²  通过“属性”对话框更改外观

·         请选择手型工具或“选择标注”命令。

·         右击要设置外观的测量标记,然后从上下文菜单中选择“属性”。

测量标记的排列

当您选中两个或更多测量标记时,一个工具栏会浮动在标记上方。直接点击相应的按钮可以居中、对齐或分布选定的测量标记。您也可以从右侧面板的“格式”选项卡中或这些标记的右键菜单中找到这些按钮。


这条信息是否有帮助?   是 否
请求新图片。